Brio performance issues

Khusus member forum yang sudah register dengan facebook dan twitter, dan tidak bisa login, silahkan lakukan reset password
  • Its been 1 year and 10,000 KM , so far car is performing very good,


    however I am facing issues for last few days - I feel that car is running sluggish


    Things that i done-
    1) i recently changed oil
    2) changed air filter also


    But still, car is not as responsive as before, engine doesnt feel peppy


    What other things can i do?

  • Your car battery is really important to its performance. Have you check the battery? Is it in good condition?


    If you used high octane and good petrol, you don't need to worry about carbon build up in your engine. But if you didn't, better to think about carbon cleaning your engine.

  • I have noticed that whenever i change to new oil, it takes a few days for the oil to make an impact - As is the oil additive package takes time to embed on the internals.


    Anyways....my car has 10,000 km and i usually dont go above 3000 rpm.


    I did "italian tuneup", which means I red lined it (after warmup) and it seems to run better.


    What this means is that there may be carbon buildup somewhere because I dont rev hard. These engines should be revved hard once in a while.


  • Could you elaborate that impact? As for me, my Brio feel lighter right away after oil changing.
    Did you do the italian tune up when your car was stay still ?


    Difficult to explain about the oil change. Maybe it was just a 'feeling'


    Italian tuneup was done on highway.



    Also, its cold here this time of the year, about 5'C. Maybe cold weather is putting more drag - not sure.


    Will need to wait and see by summer.


    All I can say is that it definitely does not feel light as it use to when it was new, but its slightly better after the tuneup.

  • 5W in 5W30 means 5'C right? If yes, then may be good idea to go for 0W30


    However, it seems to be running fine after "italian tuneup" ;;)


    My car never seen above 3000 rpm last 1 year, so its a good idea to touch the redline once in a while - dont do it too much.


    How do you guys cope with carbon deposits? Is that ever an issue?


    The info i found on fitfreak is contradicting. Some complain of carbon deposits on L series, others say simple things like oil change prevents carbon issue.


    I have been changing my oil regularly, engine is clean from inside, ofcourse i cant see inside the intake manifold/

  • 5W 30 show that your oil has multi-grade viscosity; 5 is a viscosity at cold temperature (W stands for winter), and 30 is a viscosity at 100' C.
    the bigger the number, it means the oil is thicker, and the smaller the number, your oil is thinner.


    So, If you have winter, you should pay attention to your oil spec, especially the number in front of W.


    Regarding carbon deposits, we use high octane gasoline, high octane makes better combustion, thus leaving a little carbon deposit. They're more expensive, but cheaper in the long run, maintenance wise.


    And once in a while, let say 20.000 kms, treat your engine with carbon cleaning.

  • Things are better now, its all good, car is running peppy again. It was very cold last week, so i am not sure if it was related to that!


    I am getting 16.2 KM/L mileage city/express mix driving. This is because its winters now and AC is not used.


    I hope to do SEAFOAM before 20,000 KM.



    [btw forum layout is changed, i cant find sub categories]